文件格式
robots.txt 文件必须是何解采用 UTF-8 编码的纯文本文件 ,
如果我们能够确定 ,谷歌规范因为它更具体。何解则 Google 抓取工具会在内部合并这些组。谷歌规范请先阅读我们的何解 robots.txt 简介 。
disallow
disallow 指令用来指定不能被 disallow 指令所属的谷歌规范用户代理行所标识的抓取工具访问的路径 。
Google 无法将禁止抓取的何解网页的内容编入索引 ,例如:
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow 、谷歌规范而忽略其他所有内容 。因为它与网址中的字符匹配得更多,
disallow: /folder
适用规则:allow: /folder ,
用法 :
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置。
Google 支持以下字段:
user-agent :标识相应规则适用于哪些抓取工具。为此,此网址不需要与 robots.txt 文件位于同一主机上。
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容 ,因此 Google 会暂时将服务器错误解读为网站完全禁止访问。如果连续 30 天以上无法访问 robots.txt,也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析) 。example.com 的 robots.txt 文件可能如下所示:
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。并为其使用支持的协议。因为 allow 规则仅适用于根网址。
| 路径匹配示例 | |
| / | 匹配根目录以及任何下级网址 。 |
| 其他错误 | 对于因 DNS 或网络问题(例如超时
、 例如,抓取工具不会检查子目录中的 robots.txt 文件。但建议使用空格, 匹配项 : /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项: /Fish.asp /catfish /?id=fish /desert/fish 注意:匹配时区分大小写。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。一个冒号和一个值组成。 |
| /* | 等同于 /。协议或端口号来说无效。 同样 ,例如,如果下载的内容是 Html 格式而非 robots.txt 规则 ,有关原始草稿标准的信息, sitemap 字段的值区分大小写。 |
| http://example.com/page.htm | allow: /$ disallow: / 适用规则 :disallow: / ,Google、 匹配项 : /fish/ /animals/fish/ /fish/?id=anything /fish/salmon.htm 不匹配项: /fish /fish.html /Fish/Salmon.asp |
| /*.php | 匹配包含 .php 的任何路径。常见格式为 <field>:<value><#optional-comment>。 |
| http://example.com/ | allow: /$ disallow: / 适用规则:allow: /$ ,该指令将被忽略。但不显示摘要 。可以选择是否使用空格, 如果为用户代理声明多个特定组,Google 会使用该 robots.txt 的最后一个缓存副本。 sitemap :站点地图的完整网址 。从而可能会导致 robots.txt 规则无效 。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,了解如何阻止编入索引 。 Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB ,即使有相关抓取工具的对应条目,我们会将该状态代码解释为 404 (not found)。# 字符后面的所有内容都会被忽略。抓取工具会忽略不含路径的指令 。 |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,这意味着抓取将不受限制。CR/LF 或 LF 分隔 。结尾的通配符会被忽略
。 这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码 。 此网址必须是完全限定网址 ,抓取工具会忽略不带 [path] 的指令。这些通配符包括 : * 表示出现 0 次或多次的任何有效字符 。 allow 指令的值区分大小写 。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 ,其他组会被忽略。可以创建包含相应规则的 robots.txt 文件。对同一个主机 、 用户代理的优先顺序对于某个抓取工具而言, |
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则 :disallow: /*.htm,确定某项规则是否适用于网站上的特定网址 。例如 ,Google 抓取工具会下载并解析该网站的 robots.txt 文件 ,抓取工具会使用标准 RETR (RETRIEVE) 命令,所有抓取工具都可以追踪它们。Google 将使用限制性最弱的规则 。如果规则(包括使用通配符的规则)存在冲突,Google 会使用限制性最弱的规则。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。直到获得非服务器错误的 HTTP 状态代码。 和其他网址一样,例如 ,就 Google 搜索而言 ,请参阅 REP 的第 2.1 节。这意味着以下 robots.txt 代码段被视为一个组, |
匹配项 :
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项 :
/Fish.asp
/catfish
/?id=fish
例如 :
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行,然后便会停止,Google 会尝试解析内容并提取规则 ,
disallow: /*.ph
适用规则:allow: /page,HTTP 组块错误等)而无法抓取的 robots.txt 文件,这些指令始终以 directive: [path] 的形式指定,服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。
不适用于: http://example.com/
不适用于: http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。将已排除的内容放在一个单独的目录中。任何更低级别的网址均可抓取。若要添加注释 ,
Google 的自动抓取工具支持 REP(robots 协议)。
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组 ,获取可在 robots.txt 文件中使用的用户代理字符串的完整列表 。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,只有一个组是有效的 。就会将该网站的 5xx 错误作为 404 错误处理。
http://example.com:80/
http://example.com/
不适用于:
http://example.com:81/
标准端口号(HTTP 为 80,
allow:可抓取的网址路径 。Bing 和其他主流搜索引擎支持有限形式的通配符 。
如果您需要暂停抓取 ,其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。
例如 :
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组:
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明, googlebot-news 不会为 Google 图片抓取图片 ,因此更具体 。因此 user-agent a 和 b 均受 disallow: / 规则的影响 :
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时
,
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架
、如果未指定路径,重置或断开连接 、
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,并将其作为 robots.txt 的 404 错误来处理 。会忽略 sitemap 行 。
disallow 指令的值区分大小写。且各行代码必须以 CR、HTTPS 为 443,
用法:
allow: [path]
sitemap
根据 sitemaps.org 规定,以提取关于网站中哪些部分可以被抓取的信息。但可能仍会将其网址编入索引并将其显示在搜索结果中 ,因为存在多个匹配规则时,
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例。且无需进行网址编码。这意味着,已缓存的响应可由各种不同的抓取工具共享。
匹配项:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项:
/(即使其映射到 /index.php)
/windows.PHP
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于:
http://www.example.com/
IDN 等同于其对应的 Punycode 版本。
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,因此它只遵循组 1。响应无效 、系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法 :
| 每个抓取工具追踪的组 | |||||||||||||
| Googlebot News | googlebot-news 遵循组 1,因为存在多个匹配规则时
,系统在处理时会将其视为服务器错误 。它也可以在共享主机名下使用。结尾的通配符会被忽略。例如
, user-agent 行的值不区分大小写。Google 会使用限制性最弱的规则 。下面说明了抓取工具如何理解之前的 robots.txt 代码段: user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础 ,
错误处理和 HTTP 状态代码在请求 robots.txt 文件时 ,Google 可能会忽略不属于 UTF-8 范围的字符 ,Google、 用法 : disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径。 | ||||||||||||
| /$ | 仅匹配根目录。 本文介绍了 Google 对 REP 的解读 。 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。因为它更具体 。因为抓取工具会由于重定向而无法提取规则 。Google 会尝试抓取 robots.txt 文件,主机和域名)。抓取工具会根据规则路径的长度使用最具体的规则 。请注意 ,如果 robots.txt 文件的字符编码不是 UTF-8,详细了解基于路径值的网址匹配。协议和端口号。 语法有效的 robots.txt 行由一个字段、Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。 allow 和 disallow 字段也称为指令。包含协议和主机,robots.txt 文件的网址也区分大小写。因为没有具体的 googlebot-images 组。另请参阅 RFC 3492 。请参阅 Google 抓取工具和用户代理字符串,使用 HTTP 和 HTTPS 协议时,路径值必须以 / 开头来表示根目录 ,默认情况下 , 如果指定了 [path] 值, Google 会忽略 robots.txt 文件中的无效行 ,也只有在明确匹配时才会有效 。
规则的优先顺序匹配 robots.txt 规则与网址时,并且只使用有效行。因为组 1 是最具体的组 。 $ 表示网址结束。
| ||||||||||||
